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About SWIFTwx 
SWIFTwx is an automated Internet downloading and GPS integration tool written for Storm 
Chasers, Storm Spotters, and Emergency Management Personnel. 
 
About SWIFT WX, LLC 
SWIFT WX, LLC is a premier developer of location-based decision support systems. 
SWIFTwx, our flagship product, empowers Storm Chasers to focus on what they do best: 
pursuing severe weather. Integrating with GPS technology, SWIFTwx is the only software 
available that can plot your current position over any weather map. 
 
To get in touch with us, visit our website online: 
 
http://www.swiftwx.com 
 
Or, e-mail us at: 
 
contact@swiftwx.com 
 
SWIFTwx™ is a trademark of SWIFT WX, LLC. 
 

Copyright © 2003, SWIFT WX, LLCNo portion of this work may be duplicated in any form, 
other than “Fair Use” excerpts for the purposes of critique, without the express written 
consent of SWIFT WX, LLC. 

http://www
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What is SWIFT WX? 
SWIFTwx is an automated Internet downloading and GPS integration tool written for Storm 
Chasers, Storm Spotters, and Emergency Management Personnel. 
 
Track your position over any weather map 
SWIFTwx integrates with GPS technology to plot your current 
position over radar, satellite, surface maps, or any other 
conceivable weather product. Overlay topographical features 
like roads and cities, storm attributes, surface observations, 
mesoscale discussions, convective outlooks, watches, and 
warnings onto your map.  
 
Know where the storm is and how to intercept it.  

 
Plot the path of tornadoes and thunderstorms 

With SWIFTwx's exclusive StormPath warning technology, you can know what the 
storm is "thinking." The paths of severe storms are plotted over any weather map, 
indicating bearing, intensity, and velocity. You can also drill down into storm data, 
viewing reporting station, cell ID, direction, speed, and other important variables 
 

Automatically download Internet weather data 
SWIFTwx is geared for storm chasers in pursuit of severe weather. Using pre-defined 
catalogs, chasers can download only the pertinent weather data without browsing 
through pages of irrelevant information. You can also animate a time series of maps to 
view a storm’s progression. 
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Version History 
Version 2.0 

 Totally reworked user interface  
 Custom Geographical Overlays  
 New Storm Alert Perimeter warns of weather in a defined area 
 View storm attributes, surface observations, mesoscale discussions, convective 

outlooks, watches, and warnings 
 Map download runs as separate process  
 Set different download schedules for each map element  

Version 1.3 

 Enhanced Nowcasting Features  
 Waypoint Overlays  
 Storm cell movement indicators  
 New StormPath Warning options  
 Proxy support added  
 Redundant warning data streams  

Version 1.02 

 DeLorme Tripmate now supported  
 Adjusted DeLorme Earthmate satellite lock signal colors  
 Improved breadcrumb spacing and options  

Version 1.01 

 Initial public release  
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Getting Started 
To quickly get started using SWIFT, select from the following topics:  
 

 Quick Tour 
Take a virtual tour of SWIFTwx’s features and capabilities. 

 Connecting to the Internet 
How to configure your Internet connection. 

 Downloading Maps 
The basics of downloading weather maps. 

 Viewing Maps 
How to view and manipulate the images you download. 
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Quick Tour 
SWIFTwx includes a few sample catalogs with the default installation. Using one of these, 
we'll take a quick tour of SWIFTwx's features and capabilities. 
STEP 1: Connect to the Internet 
You must be connected to the Internet to start the program. 
STEP 2: Load Program 
After installing SWIFTwx, run the program. The main interface components are menus, 
toolbars, several informational panels, and the map display space. Common functions are 
contained on the toolbar.  
Appearing on the left are two windows: the catalog, containing weather maps and status 
indicators, and the download queue, listing maps that are scheduled for download.  
Downloaded weather maps are displayed in the map display area in the center, and 
underneath is the Storm Attributes Table, which has several tabs for various data types.  
On the right, a listing of various map layers appears at the top, followed by the GPS 
position summary, and the Detail/Query table, which shows details of any weather object 
selected either on the map or in the Storm Attributes Table. 
STEP 3: Open Catalog 
Open the "Southern Plains Radar" catalog from the directory where SWIFTwx was installed. 
Click File > Open Catalog and browse to the Catalogs directory under the SWIFTwx 
program directory. Select "Southern Plains Radar.swx". 
STEP 4: Open Map 
Double-click the first map listed, National Radar. The NWS National Radar Reflectivity map 
will open in the map display area. 
STEP 5: Manipulate Image 
You can click and drag to reposition the image using the Hand tool. Or use the Zoom tool 
to zoom in (left-click) or out (right-click) on an image. By clicking and holding, you can draw 
a rectangle around an area to zoom or un-zoom. You will notice that the weather map is 
placed upon a larger US map, and you can use either the hand tool or the scroll bars on 
the sides of the map area to view other areas. 
STEP 6: Automated Downloading 
Check off several maps in the Catalog to enter them into the Download Queue. You can 
set the interval at which each map is downloaded individually using the Catalog Editor. To 
download a map immediately, double click its entry in the Download Queue. If you use a 
modem to connect to the Internet, you must connect first before using SWIFTwx. 
 
To bring another map into focus in the map display area, either double click its listing in the 
Catalog window, or click on its tab at the top of the map display area.  
STEP 7: GPS Integration 
If you own a GPS receiver, turn it on and let it initialize. If your GPS supports it, set the 
output mode to NMEA format (see GPS Settings for help on this). Once the GPS has 
initialized, connect it to the computer and click the green arrow icon on the toolbar to 
begin tracking your position over the open map. If your GPS receiver requires computer 
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software to initialize, such as the DeLorme Earthmate, connect it to the computer first, then 
click the icon. 
STEP 8: Getting Information on Storms 
When SWIFTwx detects storm observations, it plots them on the map. Select the arrow tool 
and click one of the small white circles. The reporting station is highlighted in the Storm 
Attributes Table and detailed information about its observations appears in the 
Detail/Query window. 
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Connecting to the Internet 
SWIFTwx can use any method to access the Internet including modem, DSL, cable 
modem, and satellite. In most cases, no settings will have to be changed. 
INTERNET CONNECTIONS 
To use SWIFTwx connect to the Internet the way you usually do. SWIFTwx will automatically 
use your existing connection. However, SWIFTwx will not automatically dial your modem or 
set up your Internet connection. You must manually establish your connection before 
starting SWIFTwx. 
STEP 1: Configuring Internet Explorer 
On Win32 platforms, certain Internet Explorer (IE) settings can affect your Internet 
connection. Start an instance of IE and open the Internet Options menu. This should be 
located under Tools on the menu bar. Select the Connections tab. If you use a modem to 
connect to the Internet, make sure Dial-up settings are correct. On the Connections tab, 
the Dial-up setting should be set to Dial whenever a network connection is not present 
or Always dial my default connection.  
SWIFTwx will automatically use whatever Internet connection you have established. 
STEP 2: Disconnecting  
SWIFTwx will not automatically disconnect from the Internet after downloading is complete. 
You will need to disconnect manually. You may want to do this, for example, when using a 
cell phone to connect to the Internet since minutes must be kept to a minimum.  
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Downloading Maps 
With SWIFTwx's pre-configured catalogs, downloading weather maps from the 
Internet has never been easier. The following instructions outline a few different 
ways to download weather maps. 
DOWNLOADING MULTIPLE MAPS 
STEP 1: Start Program 
 
STEP 2: Open Catalog 
Click File > Open Catalog and browse to the directory where the catalog is located 
SWIFTwx catalogs are denoted by the .SWX extension and are stored in the Catalogs sub 
directory of the SWIFTwx installation. Select the catalog 
you wish to view and click Open.  The SWIFTwx 
installation includes several sample catalogs.  
STEP 3: Select Maps 
After loading the catalog, click 
the checkbox next to the maps 
you wish to download (see 
picture). This enters them into 
the Download Queue. 
STEP 4: Begin Download 
You can set the interval at which each map is 
downloaded individually using the Catalog Editor. See the 
Catalog Editor section for more information. To download 
a map immediately, double click the entry in the 
Download Queue.  
Note: You can display the most recently downloaded 
version of a map by double clicking the map name in the 
Catalog window. This does not schedule automatic 
download, however; you must click the map’s checkbox in 
the Catalog window to place it in the download queue.  
The maps in the Download Queue download according to their individual schedules, which 
you can set using the Catalog Editor. For example, some maps may be set to download 
every two minutes, while others may download every five minutes. While downloading, a 
Download Progress panel indicates the status of the map and other element downloads. 
DOWNLOADING INDIVIDUAL MAPS 
Double-click on any map in the Download Queue to download only the individual map. You 
must first put the map in the queue by selecting its checkbox in the Catalog window. 
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Viewing Maps 
SWIFTwx offers several advantages over typical browsers while viewing weather maps. 
Animating, panning, zooming, and displaying the map superimposed over a US map are 
just a few of the available features. 

MAP TOOLBAR 

 

 Use the Arrow tool to display information about objects on the map such as 
mesoscale discussions, warnings, and watches. Position the pointing hand over the 
object’s icon on the map and click. Information is displayed in the Detail/Query window 
and the corresponding entry is highlighted in the Storm Attributes Table. 

 Use the Hand tool to reposition the map by clicking and dragging. 

 Use the Zoom tool to zoom in (left-click) or out (right-click) on an image. 
The Reset button restores the image to its original dimensions. 

  
Use the Image Animation Controls to control map animation. You use them like a VCR. 
Press the arrow to start animation; press the square to stop. Clicking the double-left icon 
will slow down map animation, and clicking the double-right will speed up. This assumes 
the map has been configured for animation using the Catalog Editor. See the Using the 
Catalog Editor section for help. 

 

MAP LAYERS WINDOW 
Use this window to control the information overlaid on the map. The types of information 
you can overlay depend on whether you have the standard installation or SWIFTwx 
Professional. Both versions have the following data types. You control the display by 
checking or unchecking the boxes for: 

GPS – Overlays your current position information from your GPS device (if installed). 
If Show Trail is enabled in Application Settings, breadcrumb icons track your previous 
positions. 

Storm Attributes – Connected round icons representing observations made by 

reporting stations can be overlaid on the map. Using the arrow tool  to click on the 
icons displays details in the Detail/Query window. 
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Surface Observations – Stickpin icons are overlaid on the map indicating surface 

observation data made by reporting stations. Use the arrow tool  to click on the icons 
to display details in the Detail/Query window. 

Warnings – Colored, shaded polygons representing warning areas are overlaid on 

the map. Use the arrow tool  to click on the warning area edges in to display details in 
the Detail/Query window.  

Watches – Overlays colored, shaded polygons representing watch areas on the 

map. Use the arrow tool  to click on the watch area edges to display details in the 
Detail/Query window. 

Mesoscale Discussions –Colored, shaded, rounded shapes representing mesoscale 

discussion areas are overlaid on the map. Use the arrow tool  to click on the 
description in the mesoscale discussion area to display details in the Detail/Query window. 

Convective Outlooks – Overlays colored, shaded, rounded shapes representing 

convective outlook areas on the map. Use the arrow tool  to click on the description in 
the convective outlook area to display details in the Detail/Query window. 

SWIFTwx Professional Additional Data Types 
In addition to the standard data overlay types, SWIFTwx Professional adds the following 
Custom Overlay types as well as the ability to create your own overlay types: 

 Interstates  
 Highways 
 Major Cities 
 Midsize Cities 
 Minor Cities 
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Tracking Your Position with GPS 
To track your position with GPS, review the following topics:  

 GPS Requirements 
Minimum requirements before you can start tracking your GPS 
position. 

 GPS Settings 
How to configure your GPS receiver and SWIFTwx settings. 

 GPS Operating  
The basics of using GPS technology in SWIFTwx. 

 GPS Troubleshooting 
Troubleshoot common GPS-related errors. 
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GPS Requirements 
To take advantage of SWIFTwx's integrated GPS technologies, your unit must meet 
the following requirements. 

GPS RECEIVERS 
 
You may use any GPS model as long as it conforms to these requirements and can 
interface to your computer. The following GPS Receivers are supported: 

 DeLorme Earthmate (http://www.delorme.com/earthmate)  
 DeLorme Tripmate (http://www.delorme.com)  
 Any NMEA-compatible GPS  

NMEA-compatible GPS receivers include most Garmin, Magellan, 
and Lowrance units. Check your GPS manual for reference. 
Below are some of the compatible models and manufacturers’ 
Web sites: 

 Garmin 12 / 65 / 76 / II+ / III+ / V / eMap / StreetPilot / 
NavTalk / GPSMAP / eTrex 
(http://www.garmin.com/mobile/products.html) 
   

 Magellan 310 / 315 / 320 / 330 /  
(http://www.magellangps.com) 
   

 Lowrance GM1600 / GM3000 / LMS-160 
(http://www.lowrance.com/) 
   

DATA CABLE 
 
The data cable connects your GPS to your computer. The cable is proprietary and can 
usually be obtained from the manufacturer. 

MAP CALIBRATION 
 
The final requirement is a software prerequisite. In order to display your GPS position over 
a particular weather map, the map must first be calibrated. This basically means that the 
map must be configured using the Catalog Editor with the proportionate latitude and 
longitude dimensions for its geographical location.  
In most cases, catalogs you use with SWIFTwx will already have every map calibrated. But 
if you add your own maps they will need to be calibrated. See the Catalog Editor section for 
more information on calibration. 
 

http://www.delorme.com/earthmate
http://www.delorme.com
http://www.garmin.com/mobile/products.html
http://www.magellangps.com
http://www.lowrance.com/
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ADDITIONAL ACCESSORIES 
 
Most GPS receivers that operate on batteries usually only last about 4-8 hours. If you are 
mobile, you may want to get a DC power supply cable that will allow your GPS receiver to 
run off the car battery. 
Power supply cables, like data cables, are custom to your make and model of GPS. 
Contact the manufacturer for assistance. 

 Garmin cables and accessories can be obtained at: http://shop.garmin.com  
 Lowrance cables and accessories can be obtained at: 

http://www.lowrance.com/accessories/default.asp  
 DeLorme cables and accessories can be obtained at: 

http://www.delorme.com/bargains/earthmate/moreinfo.asp 

 

 

http://shop.garmin.com
http://www.lowrance.com/accessories/default.asp
http://www.delorme.com/bargains/earthmate/moreinfo.asp
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GPS Settings 
Depending on your make and model, you may have to configure your GPS before 
using it with SWIFTwx. The following instructions will help you get started. 
STEP 1:  Configuring your GPS receiver for NMEA-output 
Most GPS receivers use a proprietary data format. In order to use your GPS with SWIFTwx, 
you must configure it to output data in NMEA-format. Consult your GPS manual for 
assistance. 
Note: this step does not apply for the DeLorme Earthmate and Tripmate. 
STEP 2: Configuring SWIFTwx 

Click Settings > Application Settings >GPS. Select either NMEA-0183 Protocol or the 
appropriate Delorme receiver from the drop-down list labeled Device Protocol.  
Next, select the Comm Port that your GPS is communicating over. In most cases, this will 
be COM1 or COM2.  
The rest of the settings on the GPS tab, such as Baud Rate and Parity will automatically 
default to the correct settings. Do not change these settings unless you have a reason to 
do so. 
Select Show Trail if you want SWIFTwx to plot a breadcrumb trail to mark your path. 
Select OK or Apply to save the settings. 
 

 



  SWIFTwx User Manual – version 2.0 

 Copyright © 2002-2003, Groves Internet Consulting, LLC  19 

 All rights Reserved 

GPS Operating 
The following instructions will help you get started using your GPS with SWIFTwx. 
You may need to configure your GPS settings before attempting to use it with SWIFTwx. 
Please consult GPS Settings for more information. 
STEP 1: Connect your GPS to your computer  
Using the data cable, connect your GPS receiver to your computer. In most cases, the 
cable will connect to the 9-pin serial port on your computer. Consult your GPS manual for 
assistance. 
STEP 2: Turn on the GPS 
If applicable, turn on the GPS and let it initialize. 
STEP 3: Activate the GPS 

If you have not already started SWIFTwx, do so. Then click on the toolbar. This 
initiates communication with the GPS unit. Click the icon again to disconnect. 
STEP 4: Stop GPS 

To stop tracking your GPS position, click the green arrow  on the toolbar. 
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GPS Troubleshooting 
Things can go wrong trying to get your GPS to talk to your computer. The following 
are solutions to several common problems you might encounter. 
If your GPS never makes a valid connection, please verify that: 

 Batteries are charged (if applicable)  
 Cables are securely connected  
 COM port and other GPS settings are correct  
 GPS receiver is turned on (if applicable)  
 GPS receiver is in the correct output mode (i.e., NMEA)  

Please keep in mind that some GPS models take several minutes to initialize. According to 
the DeLorme Earthmate manual, initialization may take up to 15 minutes the first time.  
If you still need assistance, contact your manufacturer to determine if your receiver is 
defective.  
For issues that might be related to SWIFTwx, contact us via our website:  

 http://www.swiftwx.com  

Or send e-mail to:  

 support@swiftwx.com  

 

 

http://www.swiftwx.com
mailto:support@swiftwx.com
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Storm Tracking Settings 
SWIFTwx users can plot the actual path of a tornado or thunderstorm as well as 
several other types of weather data. Use the following steps to configure the various 
Storm Tracking options. 
STEP 1: Start SWIFTwx 
STEP 2: Open Storm Tracking Setting. Click Settings > Storm Tracking Settings. 

Warnings Settings 
STEP 3: Click the Warnings listing. Here you can change the URL from which to download 
storm warnings and the download interval. 
Click on the plus sign (+) next to the Warnings listing to see individual settings for 
Tornado, Severe Thunderstorm, and Flash Flood warnings. For each warning type you can 
set: 

 Warning Box Color  
 Warning Box Border Width  
 Box Opacity (whether other map features show through box) 
 Show Description 
 Show Direction 
 Show Speed 
 Show Time Expires 
 Alert sounds – two sounds are included with the default install of SWIFTwx: a 

tornado siren and rumbling thunder. You can assign your own custom sounds 
 
NOTE: If both Tornadoes and Thunderstorms are present, the Tornado warning 
sound will take precedence.  

STEP 4: Click OK or Apply to save your settings 

Watches Settings 
STEP 5: Click the Watches listing. Here you can change the URL from which to download 
storm watches and the download interval. 
Click on the plus sign (+) next to the Watches listing to see individual settings for Tornado, 
Severe Thunderstorm, and Flash Flood warnings. For each watch type you can set: 

 Watch Box Color  
 Watch Box Border Width  
 Border Opacity (whether other map features show through box border) 
 Show Description 
 Show Effective Time 
 Alert Sound  

STEP 6: Click OK or Apply to save your settings 
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Storm Attributes Settings 
STEP 7: Click the Storm Attributes listing. Here you can change the URL from which to 
download storm attributes and the download interval. 
Click on the plus sign (+) next to the Storm Attributes listing to see individual settings for 
Filter, Centroid, TVS, Meso, and Hail. Each data type has its own particular settings. 

Filter – You can control the geographies for which you get storm attributes. Check the 
geographies and either Include to get attributes for the area, or Exclude to not get 
attributes. Click Apply filter to turn on filtering. 

Centroid  – You can control: 

o Centroid Color  
o Line Width  
o Show Centroid 
o Show Track 
o Show Cell ID 
o Alert Sound  

 TVS – You can control: 

o Show TVS (Tornado Vortex Signature)  
o Alert Sound  

Meso – You can control: 

o Show Mesocyclones  
o Alert Sound 

Hail – You can control: 

o Show Hail  
o Alert Sound 

STEP 8: Click OK or Apply to save your settings 

Mesoscale Discussions Settings 
STEP 9: Click the Mesoscale Discussions listing. Here you can change the URL from 
which to download mesoscale discussions and the download interval. 
Click on the plus sign (+) next to the Mesoscale Discussions listing to see individual 
settings for Tornado Watch, Severe Watch, Severe Potential, Heavy Rain, Heavy Snow, 
Freezing Rain, Mixed Precip, and Other. For each element type you can set: 

 Element Color  
 Element Border Width  
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 Opacity (whether other map features show through box) 
 Show Description 
 Show Effective Time 
 Alert Sound  

STEP 10: Click OK or Apply to save your settings 

Convective Outlooks Settings 
STEP 11: Click the Convective Outlooks listing. Here you can change the URL from 
which to download convective outlooks and the download interval. 
Click on the plus sign (+) next to the Convective Outlooks listing to see individual settings 
for General, Slight, Moderate, and High. For each outlook type you can set: 

 Element Color  
 Element Border Width  
 Opacity (whether other map features show through element) 
 Show Description 
 Show Effective Time 
 Alert Sound  

STEP 12: Click OK or Apply to save your settings 

Surface Observations Settings 
STEP 13: Click the Surface Observations listing. Here you can change the URL from 
which to download surface observations and the download interval. 
Click on the plus sign (+) next to the Surface Observations listing to see individual 
settings for Filter, Symbol, Temp Colors, Dew Colors, and Wind Colors. Each data type has 
its own particular settings. 

Filter – You can control the geographies for which you get surface observations. Check 
the geographies and either Include to get attributes for the area, or Exclude to not get 
attributes. Click Apply filter to turn on filtering. 

Symbol Settings  – You can control: 

o Show Station ID  
o Show Cloud Cover 
o Show Temperature 
o Show Pressure 
o Show Dewpoint 
o Show Pressure Rise 
o Show Wind Barb 
o Show Weather Depiction 

 



SWIFTwx User Manual – version 2.0 

24 Copyright © 2002-2003, Groves Internet Consulting, LLC   

 All rights Reserved 

Temp Colors, Dew Colors, Wind Colors  – You can add temperature, dew point, or 
wind speed values and associated colors. Type the temperature (in Fahrenheit) in the 
Degree box, and click on the Color box. From the palette that appears, select the color 
to assign. Select Add to add the temperature to the grid. Select a temperature in the 
grid and select Remove to remove. 

STEP 14: Click OK or Apply to save your settings 

Storm Alert Perimeter 
STEP 15: Click the Storm Alert Perimeter listing. Here you can change the local 
configuration file that sets the storm alert perimeter. A storm alert perimeter is a circle 
centered on particular coordinates. SWIFTwx sounds an alert whenever severe weather is 
reported inside the circle. 

Click on the box containing three dots  to browse your local or network disks for an 
existing configuration file. Configuration files have a .config extension. 
Select Settings to view or modify existing storm alert perimeters, to add new ones, or 
remove existing ones. 
Select Add to create a new storm alert perimeter. You see a menu with several options: 

 Warnings – Select the types of warnings to include in the perimeter 
o Tornado  
o Severe Thunderstorm 
o Flash Flood 

 Watches – Select the types of watches to include in the perimeter 
o Tornado  
o Severe Thunderstorm 
o Flash Flood 

 Mesoscale Discussions – Select the types of mesoscale discussions to include in 
the perimeter 

o Tornado Watch 
o Severe Thunderstorm Watch 
o Severe Potential 
o Heavy Rain 
o Heavy Snow 
o Freezing Rain 
o Mixed Precipitation 

 Surface Observations – Select the types of surface observations to include in the 
perimeter 

o Sky – Select the cloud type from the dropdown 
 Few 
 Scattered 
 Broken 
 Overcast 

o Wind Speeds > mph – Type the wind speed threshold 
o Wind Direction – Select the wind direction from the dropdown 
o Temperature > – Type the temperature threshold 
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o Dewpoint > – Type the dewpoint threshold 
o Pressure < – Type the pressure threshold in millibars 
o Weather– Select the weather type from the dropdown 

 Rain 
 Snow 
 Thunderstorm 

 Storm Attributes – Select the types of storm attributes to include in the perimeter 
o Intensity > dbZ – – Type the intensity threshold  
o TVS – check to include Tornado Vortex Signature 
o Mesocyclones – check to include mesocyclones  
o Poss. Of Hail > – Type the percentage threshold 
o Hail Size > – Type the size threshold 
o VILs < – Type the Vertically Integrated Liquid threshold  
o Cell tops > kft– Type the cell top threshold in thousands of feet 

 Convective Outlooks – Select the types of convective outlooks to include in the 
perimeter 

o High Risk 
o Moderate Rick 
o Slight Risk 
o General Thunderstorms 

 Latitude – Type the latitude for the center of the perimeter circle 
 Longitude – Type the longitude for the center of the perimeter circle 
 City – Alternately, you can set latitude and longitude by selecting a city from the 

City Picker list by selecting the City button. Select the row for the city you choose. 
The latitude and longitude are populated into the boxes. You must close the City 
Picker before proceeding. To do so, click the X in the right upper corner of the 
box.  

Click OK to save your settings. A new storm alert perimeter entry shows in the Select 
Perimeter box. Select the boxes beside the perimeters you want to enable. 
Select Sound audible alarms on alert to play an alert sound when your criteria are met 
within your storm perimeter(s). Select Auto-center map on alert to center the map display 
on the area causing the alert. 
Click OK to save your settings 
STEP 16: Click OK or Apply to save your Storm Attribute settings 
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Storm Data Console 
You can see a consolidated list of all current warnings and other observations in the 
Storm Data Console window below the map window. The window has tabs across 
the bottom representing the various types of storm data SWIFTwx gathers. 

Surface Observations 

Surface weather observations are taken by the Automated Surface Observation System 
(ASOS) every hour (more often during active weather). 

The Surface Observations window has columns for Station, Sky, Wind Direction, Wind 
Speed, Temperature, Dewpoints, Pressure, and Weather type (Rain, Snow, 
Thunderstorm). If all columns don’t show in the current view, you can scroll right and left 
using the scroll bar at the bottom. 

The Surface Observations window has rows corresponding to the reporting stations. If all 
rows don’t show in the current view, you can scroll up and down using the scroll bar at the 
right. 

Warning Summary 
The Warning Summary window has columns for Type (Severe Thunderstorm Warning, 
Tornado Warning), Direction, Speed (in MPH), Reason (why warning was sounded: Radar 
Indicated, Spotter Indicated, etc.), Time Issued, Time Expires, and Station. 
The Warning Summary window has rows corresponding to the various active warnings. 
When a warning expires or is canceled, SWIFTwx removes it from the display. 

Mesoscale Discussions 
When conditions actually begin to shape up for severe weather, the Storm Prediction 
Center often issues a Mesoscale Discussion (MCD) statement that describes what is 
currently happening, what is expected in the next few hours, the meteorological reasoning 
for the forecast, and when/where SPC plans to issue the watch, if conditions warrant.  
The Mesoscale Discussions window has columns for Type (Severe Thunderstorm Watch, 
Tornado Watch), Time Issued, Time Expires, and ID. 
The Mesoscale Discussions window has rows corresponding to the various active MCDs. 
When an MCD expires or is canceled, SWIFTwx removes it from the display. 

Watch Summary 
The Watch Summary window has columns for Type (Severe Thunderstorm Watch, 
Tornado Watch), Time Issued, Time Expires, and ID. 
The Watch Summary window has rows corresponding to the various active watches. When 
a watch expires or is canceled, SWIFTwx removes it from the display. 
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Convective Outlooks 
A Convective Outlook (SWO) is a forecast containing the areas of expected thunderstorm 
occurrence and expected severity. SWOs are issued several times daily by the Storm 
Prediction Center up to 52 hours in advance.  Local National Weather Service offices 
sometime prepare local versions.  
The Convective Outlooks window has columns for Type (slight risk, moderate risk, high 
risk, General Thunderstorms, etc), Time Issued, and Time Expires. 
The Convective Outlooks window has rows corresponding to the various active SWOs. 
When an SWO expires or is canceled, SWIFTwx removes it from the display. 

Storm Attributes Table 
The Storm Attributes Table window has columns for Station, CellID, Latitude, Longitude, 
Direction, Speed, dbZ, TVS (Tornado Vortex Signature), Meso (Mesocyclones), POSH 
(Possibility of Severe Hail), POH (Possibility of Hail), Hail Size, VIL (Vertically Integrated 
Liquid), and Tops (altitude of the cell top). 
The Storm Attributes Table window has rows corresponding to the various active storms.  
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Creating Custom Catalogs 
To create or modify your own catalogs in SWIFTwx, review the following topics:  

 Using the Catalog Editor  
Using existing catalogs. 
   

 Creating & Modifying Catalogs 
How to create and modify catalogs. 
 

 Creating & Modifying Maps 
How to create and modify individual maps. 
   

 Calibrating a Map 
How to calibrate your maps for GPS use. 

 Finding Maps 
Where to look to find maps to add to your catalog.  
 

 Setting Animation Frames 
 
Determine the number of frames to use in map animations.  
 

 Setting Download Intervals 
 
Determine how often to download a map. 
 

 Changing Other Map Properties 
 
Changing map title, URL and other settings 
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Using the Catalog Editor 
Use the SWIFTwx Catalog Editor to set up new maps to download and to change the 
properties of existing maps, including changing the download interval and 
animation. You can also create new catalogs and save copies of existing catalogs 
The following steps are common to all uses of the SWIFTwx. 
STEP 1: Start the SWIFTwx Catalog Editor. 
STEP 2: Using File > Open, locate and open the catalog containing the map you wish to 
animate. Catalogs are normally stored in the Catalogs subdirectory under the SWIFTwx 
installation directory. 
STEP 3: Select the map in the Catalog window to view the Map Properties in the 
Properties window. The window contains entries for Title, URL, Last Updated, ID, 
Username and Password (if required by the download Web site), Checked (whether the 
map is scheduled for automated download), Download Interval, Animation Frames, 
Headers, and map calibration coordinates (Left, Top, Right, Bottom). 
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Creating & Modifying Catalogs 
Follow these steps to put together your own catalog of weather maps: 

CREATING CATALOGS 
STEP 1: Start the SWIFTwx Catalog Editor. 
STEP 2: Create Catalog 
Click File > New Catalog. A blank catalog is created, entitled New Catalog.  
STEP 3: Name Catalog 
Select the name, New Catalog in the Catalog window, then click on it again (do not double-
click). A box appears around the name. Type the new name and press Enter.  
STEP 4: Add Maps 
Now you are ready to add weather maps to your catalog. For instructions on how to do this, 
refer to the topic on Creating & Modifying Maps. 
STEP 5: Save Catalog 
Click File > Save Catalog. You are prompted where to save the catalog. The location is 
unimportant, as you can Open Catalogs from any location on your computer, but you may 
want to store them in the Catalogs subdirectory under the SWIFTwx program directory. 

MODIFYING CATALOGS 
Adding or updating maps is covered in the next section, Creating & Modifying Maps. To 
delete a map, select it and press the Delete button on your keyboard. 
To change the order of maps, you can drag-and-drop the map to the desired position in the 
catalog. 
 

 

Comment [ME1]:  Doesn’t seem to 
work in v.2 
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Creating & Modifying Maps 
Follow these steps to add weather maps to your catalogs: 
STEP 1: Start the SWIFTwx Catalog Editor. 
STEP 2: Open Catalog 
Click File > Open Catalog.  
STEP 3: Create Map 
Click Edit > Add Map, or press CTRL+Insert. A new map is added to your catalog entitled 
Untitled Map.  
STEP 4: Open Properties 
Select the map. The map’s properties appear in the Properties window.  
STEP 5: Change Properties 
Many options can be configured for a map. See the sections Map Animation: Animation 
Frames, Map Animation: Download Intervals, and Changing Other Map Properties for 
more information.  
 
At the very least, you'll need to specify:  

 Title: Name of the map that will appear in the catalog list  
 URL: URL to the map graphic on the Internet.  

 
NOTE: The URL must be the actual graphic and not the page that contains the 
graphic. Accepted graphic formats are: GIF, JPEG, and PNG.   

STEP 6: Save your changes 
The changes you make do not take effect immediately. Be sure to save your work by 
saving the catalog. Click File > Save Catalog 

If SWIFTwx is open, you will need to reload the catalog to see your changes. 
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Calibrating a Map 

To be completed by Rory 
In order to track your position over a map, it must first be calibrated. The 
following steps will show you how to do this. 
STEP 1: Open Map 
Start SWIFTwx and open the map you wish to calibrate (download it first if not already 
done).  
STEP 2: Enable Calibration Mode 
Enable Calibration Mode by clicking on the button. Three additional buttons will 

appear in the toolbar: . In addition to these buttons (1, 2, and 3), 
corresponding Calibration Markers will appear on the map. 
STEP 3: Position the Calibration Markers. 
Click and drag each Calibration Marker over a city or location on the map, forming an 
invisible triangle. Since the GPS engine will attempt to "triangulate" your position 
based on these Calibration Markers, it is best to spread out your triangle over the 
map. If in doubt, look at the Calibration Markers of 
already-calibrated maps.  
STEP 4: Assign Cities to the Calibration Markers. 
Click the down arrow on the toolbar next to the 
corresponding numbered button of the Calibration 
Marker. In the list of cities menu that appears, select 
the city that your Calibration Marker is positioned 
over. If your city is not listed in the menu, you may 
add a new city by clicking Other. Repeat this step for 
the remaining Calibration Markers. 
STEP 5: Disable Calibration Mode 
Once you have completed positioning the Calibration Markers and assigning cities, 
click the Calibration button again to leave Calibration Mode.  
STEP 6: Save Catalog 
Your map is now calibrated for GPS use and StormPath Warning plots. Be sure to 
save your work by saving the catalog. Click File > Save Catalog 
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Finding Maps 
The following information will help you locate and retrieve weather maps from the 
Internet to use with SWIFTwx. 
STEP 1: Find a Map 
The following sites provide extensive weather data and are a great resource to find maps 
to add to your custom catalogs:  

 National Weather Service - http://www.nws.noaa.gov  
 Unisys Weather - http://weather.unisys.com  
 UCAR/NCAR - http://www.rap.ucar.edu/weather  
 Ohio State University - http://twister.sbs.ohio-state.edu  
 College of DuPage - http://weather.cod.edu  
 StormTrack - http://www.stormtrack.org  

More links are available at http://www.swiftwx.com 
STEP 2: Obtain the URL 
Once you have identified a map you wish to include in your catalog, you must get the 
image URL. The easiest way to do this in Internet Explorer is to right-click on the image, 
and select Copy Shortcut.  
Sometimes the URL is not readily visible and you must view the HTML source code to find 
it. In Internet Explorer, right click on any part of the page that is not an image and select 
View Source. The page source opens in Notepad. 
STEP 3: Create the Map in SWIFTwx 

Once you have obtained the image URL, refer to Creating & Modifying Maps to add the 
map to your catalog. You will need to calibrate the map before you can use it in SWIFTwx. 
See the sections Calibrating a Map and Changing Other Map Properties for more 
information.  
   
Unisys is a registered trademark of Unisys Corporation. 

 

http://www.nws.noaa.gov
http://weather.unisys.com
http://www.rap.ucar.edu/weather
http://twister.sbs.ohio-state.edu
http://weather.cod.edu
http://www.stormtrack.org
http://www.swiftwx.com
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Setting Animation Frames 
SWIFTwx can animate any map in a catalog by caching previously downloaded 
images. You control animation in the SWIFTwx Catalog Editor. 
STEP 1: Start the SWIFTwx Catalog Editor, locate and open the catalog containing the map 
you wish to animate. 
STEP 2: Select the map in the Catalog window to view the Map Properties in the 
Properties window.  
STEP 3: Adjacent to the Animation entry in the Properties window, type the number of 
frames to use in animations. The higher the number, the more disk space the system will 
require to store each map. 
STEP 4: The changes you make do not take effect immediately. Be sure to save your work 
by saving the catalog. Click File > Save Catalog 
If SWIFTwx is open, you will need to reload the catalog to see your changes. 
You can select another map property to change, select another map or save your catalog 
and close the Catalog Editor. 
Your map is now configured for animation. From now on, each time you download the map 
a frame will be added to the animation sequence. Review the section on Viewing 
Animations for details. 
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Setting Download Intervals 
SWIFTwx can animate any map in a catalog by caching previously 
downloaded images. You control how often the system downloads new 
images using the SWIFTwx Catalog Editor. 
STEP 1: Start the SWIFTwx Catalog Editor, locate and open the catalog 
containing the map you wish to animate. 
STEP 2: Select the map in the Catalog window to view the Map Properties in 
the Properties window.  
STEP 3: Adjacent to the Download Interval entry in the Properties window, 
type the number of minutes between map downloads. The higher the number, 
the more often the system will download a new map. Type 0 to never 
automatically download the map. You will need to download the map manually. 
STEP 4: The changes you make do not take effect immediately. Be sure to save 
your work by saving the catalog. Click File > Save Catalog 
If SWIFTwx is open, you will need to reload the catalog to see your changes. 
You can select another map property to change, select another map or close the 
Catalog Editor. 
Your map is now configured for automatic download.  
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Changing Other Map Properties 
 

Using the SWIFTwx Catalog Editor, you can change other map properties, 
including the Title, URL, Last Updated, ID, Username and Password (if 
required by the download Web site), Checked (whether the map is 
scheduled for automated download), Headers, and map calibration 
coordinates (Left, Top, Right, Bottom).  

Changing Map Title and URL 
STEP 1: Start the SWIFTwx Catalog Editor, locate and open the catalog 
containing the map you wish to modify. 
STEP 2: Select the map in the Catalog window to view the Map Properties in 
the Properties window.  
STEP 3: Adjacent to the Title entry in the Properties window, type the desired 
title. This title will appear on the catalog entry as well as on the map tab in the 
map display window within SWIFTwx. 
STEP 4: If desired, you can change the URL used to download the map. You 
would do this ordinarily only if the URL changed, or if you are creating a new 
map. Be sure to test the URL in your browser and copy it exactly into the field 
adjacent to URL.  
NOTE: The URL must point to the actual graphic and not the page that contains 
the graphic. Accepted graphic formats are: GIF, JPEG, and PNG. 

Your map is now retitled and redirected to download from a different URL. The 
changes you make do not take effect immediately. Be sure to save your work by 
saving the catalog. Click File > Save Catalog 
If SWIFTwx is open, you will need to reload the catalog to see your changes. 

Changing Map ID and Password 
You may want to download maps from sites that require registration and user ID 
and password for access. After you register at the site, you can put your ID and 
Password into the SWIFTwx catalog for automated download. 
STEP 1: Adjacent to the ID entry in the Properties window, type the user ID for 
the download site. Note: the User ID and password are stored in plain text on 
your computer. 
STEP 2: Adjacent to the Password entry in the Properties window, type the 
password for the download site.  
Your map will now use the ID and Password to log-in on your behalf and 
download maps. The changes you make do not take effect immediately. Be sure 
to save your work by saving the catalog. Click File > Save Catalog. 
If SWIFTwx is open, you will need to reload the catalog to see your changes. 
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Changing Headers 
You may want to download maps from sites that require registration or other 
information from you such as a Cookie. After you register at the site, you can 
enter the cookie information or other Web header information in the Headers 
section. 
STEP 1: Adjacent to the Headers entry in the Properties window, type or copy in 
the header or cookie information from download site.  
Note: this information is stored in plain text on your computer. 
Your map will now send the header information to the download site. The 
changes you make do not take effect immediately. Be sure to save your work by 
saving the catalog. Click File > Save Catalog 
If SWIFTwx is open, you will need to reload the catalog to see your changes. 

Changing Map Coordinates/Calibrating a Map 
If you add a new map to a catalog, you will need to calibrate it – indicate how it 
fits over the US map – before you can use it. You can manually type the latitude 
of the top and bottom edges of the map, and longitude of the left and the right 
edges. Alternately, you can drag the map into the proper position on the US map 
using the Catalog Editor’s Map window. To manually calibrate the map, follow 
the following procedures. 
STEP 1: Adjacent to the Left entry in the Properties window, type the longitude 
of the left edge of the map image.  
STEP 2: Adjacent to the Top entry in the Properties window, type the latitude of 
the top edge of the map image.  
STEP 3: Adjacent to the Right entry in the Properties window, type the longitude 
of the right edge of the map image.  
STEP 4: Adjacent to the Bottom entry in the Properties window, type the latitude 
of the bottom edge of the map image.  
Your map is now calibrated for use with SWIFTwx. The changes you make do not 
take effect immediately. Be sure to save your work by saving the catalog. Click 
File > Save Catalog 
If SWIFTwx is open, you will need to reload the catalog to see your changes. 
For more information on using the Map window to calibrate a catalog, see 
Calibrating a Map. 
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Viewing Animations 
SWIFTwx can animate any map in a catalog by caching previously downloaded 
images. To view animations you have created, review the following steps. 
STEP 1: Start SWIFTwx 
STEP 2: Open the map you wish to animate. Ensure that you have downloaded at least 
two versions of the map. Otherwise, animation won’t appear to work until two map 
iterations have been downloaded. 

STEP 3: Click the right facing Arrow button  
Your map will now begin animating. The length of the animation will depend on how many 
frames have been previously downloaded and the max number of frames set for the map 
using the Catalog Editor. 

To speed up the animation, click  

To slow down the animation, click  

Click the Animate button again the pause the animation.  

Click the square Stop button  to stop the animation 
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Using the Console 
The SWIFTwx Console displays information about the operation of the program, 
including logging downloads. Its primary purpose is for troubleshooting. 
STEP 1: Start SWIFTwx 
STEP 2: Click on the Console button in the lower left corner of the program window. 
STEP 3: Select and copy any pertinent information into an email or other application. 
STEP 4: Select any other portion of the program window to close the console. 
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Using Custom Layers 
SWIFTwx can overlay various types of graphical information onto a map. These 
overlays are vector graphics representing information such as Interstates and Major 
Cities. You control the display of these Custom Layers from the Settings selection 
on the menu bar. The current set of Custom Layers appears in the Menu Layers 
window. 
STEP 1: Start SWIFTwx 
STEP 2: Click on Settings > Custom Layers.  

 
STEP 3: Select the checkbox beside the overlay type to enable it. 
STEP 4: Select Add to add a new overlay, Remove to delete an overlay, and Modify to 
change an overlay. 
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STEP 5: When you select Add or Modify, you can control the following parameters for the 
overlay: 
Title – What you type here displays in the Map Layers window when the layer is enabled 
Filepath – If you are loading the layer from a disk file, either type the file location or click 
on the box containing three dots  to browse for the file. 
Min Zoom– Rory to do 
Max Zoom– Rory to do 
Query – Rory to do 
Render – Rory to do 
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Download Engine 
With version 2.0, the download functionality is separate from the SWIFTwx program. 
Starting SWIFTwx also starts a second program called the SWIFTwx Download Engine 
(DLE). This program runs in the background and handles all the downloading of 
maps and other weather elements. When you close the main SWIFTwx program, it 
closes the Download Engine as well, so you rarely will need to concern yourself with 
the DLE. However, viewing the DLE can give you information about downloaded 
elements and the communications between your computing and the Internet. 
STEP 1: Start SWIFTwx 
STEP 2: You will notice a second program icon on the status bar at the bottom of your 
screen. This is the Download Engine. Click the icon  to switch to the 
DLE.  
STEP 3: You see two windows containing green on black entries, a status indicator, some 
totals, and a Shutdown button..  
The top window, labeled Network Communications, lists all the communications between 
your computer and the Internet. You can scroll this window up or down using the scroll bar 
on the right. Be aware that if you try to scroll while new commands are being executing, the 
window will snap down to show the most recent communications. 
The bottom window is the Command Queue, which lists the URLs and other commands 
used to process Internet retrievals. 
You may want to use these displays to troubleshoot communications problems. 
The Status display indicates the status of the download engine. 
The Totals display shows how many files and how many bytes have been downloaded in 
the current session. 
You can use the Shutdown button to stop the DLE in special situations, if, for example, the 
main program terminates abnormally and leaves the DLE running, but you should ordinarily 
just shut down the main SWIFTwx  program instead. 
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Program Reference 
To learn more about the SWIFTwx features, review the following topics:  

 The Interface 
Overview of the main interface. 
   

 Menu Bar and Toolbar 
Reference to the main menu and toolbar. 
   

 Map Toolbar 
Reference to the map toolbar. 
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The Interface 
The following graphic identifies the various interface components for SWIFTwx: Rory 
needs to label parts 

 
 
Each of the windows can be detached from the main layout by clicking on their title bars 
and dragging them to the position you desire. 
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Menu Bar & Toolbar 
The SWIFTwx Menu Bar and Toolbar provide the primary means of interface 
navigation. 

 

File Menu 

 Open Catalog: Opens a catalog from disk  
 Save Catalog [As]: Saves the current catalog to disk  
 Exit: Quit program  

View Menu 
This selection controls what elements are displayed on the screen. You can check each 
element to show it, or uncheck it to hide it. The View Menu is divided into several sections. 
The first section controls the visibility of the various informational windows: 

 Catalog: The active catalog window 
 Download Queue: The download queue and download progress bar window 
 Console: The console displays various program operational details 
 Map Layers: Controls the various informational map overlays  
 GPS Position: The GPS positional information window 
 Detail/Query: The detail/query information window 

The next section of the menu controls the tabs in the Storm Data Console: 

 Watch Summary 
 Warning Summary 
 Storm Attributes Table 
 Mesoscale Discussions 
 Convective Outlooks 
 Surface Observations 

The next section of the menu enables you to: 

 Show All: Show all windows and elements 
 Hide All: Hide everything but the Map window 

The last two selections enable you to:  

 Reset Layout: Return all windows and elements to their starting positions 
 Refresh: Update all windows  
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Settings Menu 

 Custom Layers: Open properties controlling the various informational map overlays 
 Storm Tracking Settings: Provides quick access to the Storm Tracking Settings 

section of the Applications Settings menu 
 Storm Alert Perimeter: Provides quick access to the Storm Alert Perimeter section 

of the Applications Settings menu 
 Application Settings: Open the Applications Settings menu   

Window Menu 

 Tile Windows: Tile all open maps horizontally, top to bottom  
 Tab Windows: Return all open maps to the default tabbed configuration  
 Float Windows: Detach all open map windows from the rest of the interface so they 

can be dragged 
 Close All Windows: Close all open maps  

Help Menu 

 Documentation: Open the program documentation  
 Quickstart Tutorial: View the program tutorial  
 About SWIFT WX: View version number and other program details  

GPS Icon 
Click the green arrow to start or stop communications with your GPS unit. 

Map Toolbar 
See the Map Toolbar section for more information. 
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Map Toolbar 
SWIFTwx offers several advantages over typical browsers while viewing weather 
maps. Animating, panning, and zooming are just a few of the available features. 
 

 

 Use the Arrow tool to display information about objects on the map such as 
mesoscale discussions, warnings, and watches. Position the pointing hand over the 
object’s icon on the map and click. Information is displayed in the Detail/Query window. 

 Use the Hand tool to reposition the map by clicking and dragging. 

 Use the Zoom tool to zoom in (left-click) or out (right-click) on an image. 
The Reset button restores the image to its original dimensions. 

  
Use the Image Animation Controls to control map animation. You use them like a VCR. 
Press the arrow to start animation; press the square to stop. Clicking the double-left icon 
will slow down map animation, and clicking the double-right will speed up. This assumes 
the map has been configured for animation using the Catalog Editor. See the Using the 
Catalog Editor section for help. 
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System Requirements 
Basic System Requirements:  

 Windows 95/98/2000/NT  
 Pentium III 500mhz or higher  
 128 MB RAM  
 100MB Disk Space  
 Modem or direct Internet connection (e.g., DSL, Cable Modem)  

NOTE: You must be connected to the Internet in order to start SWIFTwx. This is so your 
product license can be verified. 

GPS Integration Requirements:  

 NMEA-Compliant GPS Receiver  
 GPS-to-PC connecting cable  

Mobile/Travel Requirements:  

 Laptop computer  
 Power inverter or car battery power cable  
 Laptop mount recommended  
 Cell phone (dual-band recommended) and Cellular PC Card Modem, or  
 Cell phone with built-in modem  
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Product Activation 
In order to start using SWIFTwx, your product must first be activated. The following 
information addresses this topic.  

REQUIREMENTS 

 You have purchased a copy of SWIFTwx from SWIFT WX, LLC (at 
http://www.swiftwx.com or on CD).  

 You are connected to the Internet  

 
FREQUENTLY ASKED QUESTIONS 
Why Product Activation? 
Product Activation is simply a method of copy protection. It helps to ensure that the 
software you are using was legitimately purchased and helps to protect the investment the 
author made in developing this software. Product Activation does not restrict you from 
installing multiple copies of the software on other computers you own, or re-installing the 
software on the same computer (for example, if your hard drive crashes). 
How does it work? 
When you purchase a copy of SWIFTwx, your e-mail address is stored in our customer 
database. The first time you run the software, you will be prompted for your e-mail address. 
After verifying that you did in fact purchase the software, the application will e-mail the 
Product Key to you. Use the Product Key to complete the Product Activation form and the 
software will be activated. After a successful activation, the Product Activation screen will 
not be displayed again. 
Where can I purchase SWIFTwx? 
SWIFTwx can be purchased online at http://www.swiftwx.com. 
What e-mail address should I use? 
Use the e-mail address that was supplied at the time of purchase, or the customer e-mail 
address for your account on http://www.swiftwx.com. 
What if my e-mail address changes? 
If your e-mail address changes after the software has been activated, you do not need to 
do anything. If your e-mail address changes before you activate the software, you will 
need to update your customer account at http://www.swiftwx.com with the new e-mail 
address. 
What if my Product Key never shows up? 
The Product Key should be instantly e-mailed to you after you submit your e-mail address. 
If it does not show up, you may have entered the wrong e-mail address. If the e-mail 
address is correct and you still have not received the Product Key, contact 
support@swiftwx.com for assistance. 
What if I bought a used copy of SWIFTwx? 
If you bought a previously-owned copy of the software, the previous owner must update his 
customer account at http://www.swiftwx.com to use your e-mail address.  

http://www.swiftwx.com
http://www.swiftwx.com
http://www.swiftwx.com
http://www.swiftwx.com
mailto:support@swiftwx.com
http://www.swiftwx.com
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ERROR MESSAGES 
Rory to review and correct 
Error contacting server. Please try again. 
This means there was an error contacting the SWIFT WX server. You must have a 
connection to the Internet to complete the Product Activation. If you already are connected 
to the Internet, there may be a temporary problem with our servers. In that case, just try 
again later. If several hours have passed and you are still unable to contact our servers, 
notify support@swiftwx.com and someone will follow-up with you. 
Please enter a valid e-mail address. 
This means you did not enter a well-formed e-mail address. Your e-mail address should 
look something like jsmith@hotmail.com.  
E-mail not found in customer records. 
This means you entered the wrong e-mail address or your e-mail address has changed 
since you purchased the software. If that is the case, you will need to update your 
customer account at http://www.swiftwx.com with the new e-mail address. If you did not 
purchase the software, you will need to do that first (see http://www.swiftwx.com to 
purchase the software). 
Invalid product key. 
This means the product key you entered does not match the Product Key that was e-
mailed to you. Verify that you entered the most recently e-mailed Product Key. Also, do not 
include any dashes (-) when typing in the Product Key. 
You are not licensed for this product. 
This means that you are a customer of SWIFT WX, LLC but do not own a license to this 
particular product. SWIFTwx can be purchased online at http://www.swiftwx.com. 
Unspecified Error. 
This error is a catchall for all server-related issues. This indicates a temporary problem with 
our servers and will likely be remedied very soon. Try activating the product later. 

 
OTHER 
If you were not able to find the answer to your question here, please contact 
support@swiftwx.com for further assistance. 
 

 

mailto:support@swiftwx.com
mailto:jsmith@hotmail.com
http://www.swiftwx.com
http://www.swiftwx.com
http://www.swiftwx.com
mailto:support@swiftwx.com

